Supported Base OS Images

Overview

Base OS Images (also referred to as Worker images) are only required for clouds that do not support dynamic bootstrapping. Some clouds do not support dynamic bootstrapping and will require base Operating System (OS) image preparation. The tables in this section identify a complete list of images provided by Cisco for each cloud and OS.

OS Version Support

This page provides a list of image and support details for all clouds supported by CloudCenter. Cisco provides images for the two latest versions.

Worker Image Provided Column

This column indicates one of the following values:

IndicatorDescription
Yes

The Application VM (Worker) image is provided by Cisco.

See Virtual Appliance Overview and Phase 4 Overview for additional context.

No

The Application VM (Worker) image is not provided by Cisco.

To manually install CloudCenter using your own base OS images contact the CloudCenter Support team to obtain the manual installer instructions.


Dynamic Bootstrapping Column

If the CloudCenter platform supports bootstrapping, then the Dynamic Bootstrapping column identifies the status for that OS as Supported to indicate that CloudCenter detects a missing agent and automatically pushes the agent to the VMs at provisioning time. 

IndicatorDescription
SupportedIf Dynamic Bootstrapping is supported, you have two options:
  • Use your own publicly available images.
  • Build your own custom image and install the CloudCenter-provided image in this custom image.
Not SupportedIf Dynamic Bootstrapping is not supported (for example, VMware), you have two options:
  • Use your own custom image.
  • Build your own custom image and install the CloudCenter-provided image in this custom image.

CentOS 6

Cloud

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

Vmware

Yes

Not Supported
Azure Classic (non-government)

Yes

Supported

Azure RM (non-government)

YesSupported

Dimension Data

Yes

Not Supported

SoftLayer

Yes

Supported
AlibabaYesSupported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

Yes

Supported
Azure PackNoNot Supported

CentOS 7

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

Vmware

No

Not Supported
Azure Classic (non-government)YesSupported

Azure RM (non-government)

Yes

Supported

Dimension Data

Yes

Not Supported

SoftLayer

Yes

Supported
Alibaba

Yes

Supported
VMware vCD/vSphere/vCenterYesNot supported
OpenStack

No

Supported
Azure PackNoNot Supported

CentOS 7 – Docker

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Not Supported

Vmware

No

Not Supported
Azure Classic (non-government)

No

Not Supported

Azure RM (non-government)

NoSupported

Dimension Data

YesNot Supported

SoftLayer

Yes

Supported
Alibaba

No

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Supported
Azure PackNoNot Supported

RHEL 6

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

Vmware

No

Not Supported
Azure Classic (non-government)

No

Supported

Azure RM (non-government)

No

Supported
Dimension Data

Yes

Not Supported

SoftLayer

YesSupported
Alibaba

No

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Not Supported
Azure PackNoNot Supported

RHEL 7

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

VMware

No

Not Supported
Azure Classic (non-government)

No

Supported

Azure RM (non-government)

Yes

Supported

Dimension Data

Yes

Not Supported

SoftLayer

Yes

Supported
Alibaba

No

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Not Supported
Azure PackNoNot Supported

Ubuntu 12

See End of Life Notices for Ubuntu 12x from the CloudCenter perspective.

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

VMware

No

Not Supported
Azure Classic (non-government)

Yes

Supported

Azure RM (non-government)

Yes

Supported
Dimension Data

Yes

Not Supported

SoftLayer

Yes

Supported
Alibaba

No

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Supported
Azure PackNoNot Supported

Ubuntu 14

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

VMware

Yes*

Not Supported
Azure Classic (non-government)YesSupported

Azure RM (non-government)

Yes

Supported

Dimension Data

Yes

Not Supported

SoftLayer

Yes

Supported
Alibaba

Yes

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStackYes*Supported
Azure PackNoNot Supported

Windows Server 2008

Cisco CloudCenter requires PowerShell 4.0 to be used with Windows 2008 servers.

To verify that you are running PowerShell 4.0, issue the following command and validate the version:

PS C:\> $PSVersionTable.PSVersion

Major Minor Build Revision 
----- ----- ----- -------- 
4  0  -1  -1

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

VMware

No

Not Supported
Azure Classic (non-government)

Yes

Supported

Azure RM (non-government)

YesSupported
Dimension Data

No

Not supported

SoftLayer

Yes

Supported
Alibaba

Yes

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Supported
Azure PackNoNot Supported

Windows Server 2012

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

Yes

Supported

VMware

No

 Not Supported
Azure Classic (non-government)

Yes

Supported

Azure RM (non-government)

Yes

Supported

Dimension Data

No

Not supported

SoftLayer

Yes

Supported
Alibaba

Yes

Supported
VMware vCD/vSphere/vCenterYesNot Supported
OpenStack

No

Supported
Azure PackNoNot Supported


Windows Server 2016*

Clouds

Worker Image Provided?Dynamic Bootstrapping
AWS (non-government)YesSupported
Google Cloud

No

Not Supported

VMware

Yes

 Not Supported
Azure Classic (non-government)

No

Not Supported

Azure RM (non-government)

Yes

Supported

Dimension Data

No

Not supported

SoftLayer

Yes

Supported
Alibaba

No

Not Supported
VMware vCD/vSphere/vCenterNoNot Supported
OpenStack

Yes

Supported
Azure PackNoNot Supported


* Effective CloudCenter 4.8.1