CloudCenter 4.8 has reached End of Life (EOL) as of November 14, 2018. See End of Support Notices for additional context.

Java Version Compatibility

This section provides details on the Java-based Management agent.

If you are looking for details on the Go-based lightweight agent, see the Virtual Machines Management section.

Overview

Each VM that is managed by CloudCenter requires a Management Agent Bundle (agent) component to run on it. The CloudCenter platform installer files includes the management agent in each VM image. The CloudCenter platform detects that the agent is not installed and automatically pushes the agent to each VM as part of the deployment process.

The CCO receives monitoring information from the management agent and in turn provides instructions to the agent for the following tasks:

  • Complete application deployment tasks

  • Perform provisioning tasks (for example running configuration scripts)

  • Run custom cleanup scripts (for example to deprovision or shutdown applications)

  • Enforce policies (for example, to reconfigure middle ware service during auto-scaling)

  • Collect system metrics based on policy requirements

  • Monitor data, provide status updates, and keep alive system heartbeats.

Java Version Compatibility

CloudCenter VersionJava Version
CloudCenter 4.6.0Java 1.8 Update 102
CloudCenter 4.7.0Java 1.8 Update 102
CloudCenter 4.8.0

JVM 1.8 Update 131 (core_upgrade.bin)

JRE 1.8 Update 121 (worker_installer.bin)

CloudCenter 4.8.1

JVM 1.8 Update 131 (core_upgrade.bin)

JRE 1.8 Update 131 (worker_installer.bin)

CloudCenter 4.8.2x

JVM 1.8 Update 152 (core_upgrade.bin)

JRE 1.8 Update 152 (worker_installer.bin)

CloudCenter 4.9.0

JVM 1.8 Update 162 (core_upgrade.bin)

JRE 1.8 Update 162 (worker_installer.bin)

CloudCenter Cisco CloudCenter 4.9.1 Release Notes

JVM 1.8 Update 172 (core_upgrade.bin)

JRE 1.8 Update 172 (worker_installer.bin)

Manually Upgrade Java Version

The CloudCenter 4.8.2 worker appliance has Java version 1.8.152 installed by default in the standard location for Java: /usr/local/c3agent/jre1.8.0_152. New deployments created with CloudCenter 4.9.1 have workers appliances that use the most recent Java version. Core components with older Java versions must be manually updated for the core_upgrade.bin by using the following command to ensure that the latest compatible Java version is being used with each CloudCenter release:

core_upgrade.bin <os> <cloud>




Back to: Worker (Conditional)

  • No labels
© 2017-2019 Cisco Systems, Inc. All rights reserved